Jump to content
Kokos Goldfish Forum
Sign in to follow this  
bv_uk

Fungal Treatment? Pond.

Recommended Posts

I have inherited 9 goldfish in my new home. Initially, they were all healthy in November and ate pellets once or twice a month ( because winter) but in late February the water turned black and I never saw the fish. This is when I being a naive pond owner, cleaned the entire pond, and unknowingly scrubbed all the good bacterias. I feel like a murderer now as in the last 2 months 1 fish has died and all fish have been sick. We added pure aqua bomb 5 weeks back, tested the water and all looks fine but the fish health is no better. This includes a visit from Des Harris ( Southeast Koi club). He provided us Praziquantel for Flukes for the 1st week and FMG  for the second dose. I see at least 4 of my fish have got fungal (the fish did had the same along with bruises during spawning). So now I have added API salt in 3 parts i.e 1kg every 8 hours. In total 3 kg for 300 liters of water because I noticed few had fungus and swim bladder symptoms. I have tested the water using api drip kit( PH 7.5-8, NItrite-0, Ammonnia- 0.25, Phosphate - 0.25)

Please advice what should I do further?

Share this post


Link to post
Share on other sites

Hi,

Welcome to koko'S. How big is this pond?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
  • Create New...