Jump to content
Kokos Goldfish Forum
Sign in to follow this  
Candybugs

Equipment question

Recommended Posts

926bdd5c141ed73de8b43ddcf13dba5d.jpgwhat is the purpose of the float and spring that is on the top of my eheim canister filter head. My canister head keeps leaking . I ordered new clips for the top because 1 was broke. I cleaned the gasket seal and it's still leaking. Then I noticed I don't have that spring that goes in there. When I got it there was a round media ball in there. And what are the lines supposed to be telling me. I can't see where it's leaking from. When I take it outside to see if it's gonna leak it doesnt. I bring it back in and it leaks. Ugh help what is the spring and float for? cc1003aac799dd33173147a1f73cf231.jpgunder that red circle was one ball.

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

I'm sorry I can't help - I don't have experience with eheims but many users on here do and hopefully one can assist!

Share this post


Link to post
Share on other sites

Thanks arctic mama empathy helps too. I turn 50 in 2 days and they sent me an aarp card like I needed that today. Lol

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

34922d47b2c2c31501df276893ceda47.jpg1113e7ddbc8e13d92e25a9cc028dd9fe.jpg attempt 492 so the tube that goes from the canister down through the media baskets was shoved in too far so fixed that and that float I think is some way to tell me when it's clogging up and needs cleaning I think. This is not a good hobby. And fail again

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

I dont have an Eheim either.

Although i do know that if I have water in the top part of my canister before putting it all back together it has a tendency to leak.

Try taking the top off, emptying water from it and then reconnecting everything...cant hurt :I-Thank-You:

Ask the person you got it off, they should know the ins and outs?

If you have a LFS you could try taking it there and they may know?

Edited by Speckles

Share this post


Link to post
Share on other sites

Yes, Flow rate indicator – informs you when should be cleaned

Apparently people have taken it out with no issue :idont

 

http://www.bcaquaria.com/forum/equipment-talk-section-14/eheim-pro-ii-flow-indicator-1391/#

Edited by Speckles

Share this post


Link to post
Share on other sites

It works great when it's outside but Everytime I bring back into the house it leaks again. That's what's really getting me frustrated what's different between the big bucket outside and the tank. I don't get it.

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

9b56765491fcdc803a652fdf301e5135.jpgThis is my nightmare tank.

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

Gravity? is the bucket on the ground?

More pressure with water coming from high up maybe

Edited by Speckles

Share this post


Link to post
Share on other sites

Speckles kiss yourself for me please I took apart the primer thing and the o ring is broken . Thank god an answer.

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

And a cheap answer at that

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

All of the o ring distributors are closed on sat. What other type of buisness might have a large variety of o rings. I'm gonna start with auto parts and plumbing supply . Maybe appliance repair or sewing and vacum repair. I have the exact measurements thanks to speckles so I'm starting the hunt. I already waited for the clips from Quebec for a week. I don't want to wait till monday. I got a text from the mailman as soon as he put them in my mailbox which is the same time my grandson and I were getting on the frwy to go for my grandaughters birth. My grandson and I were both THE CLIPS.should we go back but we didn't have time she was dilated to 4 already. I had my neighbor get them for me. It was funny.

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

2 tool stores 2 pool stores and 1 aquarium supply store no o ring I came close at the aquarium store he had 4 but nor my model. Monday it is.

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

Ok I got it at Lowe's by the whirlpool water filtration systems

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

Tanks been running all night and it's all dry as a bone that god

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

Still dry added some of the water their in to the tank.

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

How is your new Granddaughter doing????

Share this post


Link to post
Share on other sites

A baby [emoji33][emoji847]

I'm so glad the filter has worked out ok, phew!

Share this post


Link to post
Share on other sites

She's great I'm on my way to see her now047286077b188ab9f7ec5235e8b36fc8.jpgthanks for asking.

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

I've been cking all day for leaks so far so good. It's so quiet too.

Sent from my SM-G900V using Tapatalk

Share this post


Link to post
Share on other sites

Sorry I missed this post.

I also had a Pro 2.  Looks like you have a 2028.

 

You and speckles are correct, that is a flow rate indicator.

 

It's great you found an o-ring that works.

 

If I can suggest a few things.  Everytime you clean the filter use plumbers silicone grease on the o-rings.  The main canister to head 0-ring, the tube adapter to head o-rings...etc.  I use a q-tip to apply it.  It will keep the o-rings from drying out and helps seal the canister.

 

Also be careful as the primer pump o-ring is notorious for leaking on the pro 2's & 3's if not maintained properly..  And it's very difficult to change as you have to take the head apart.

What I do to keep it lubricated is to spray food grade silicone or even cooking spray like Pam around the base of the primer pump button so it flows into the top of the head.  I then give the primer button about 10 -20 pumps to work in the silicone.  It totally freed up my primer button and stopped the minor leak I had from there.  It also made pumping the primer button way easier to press down.

Edited by Eddie

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
  • Create New...