Jump to content
Kokos Goldfish Forum
Sign in to follow this  
goldylove

eheim 2213 rattle, everything looks fine?

Recommended Posts

ho hum, yes another rattling impeller question! got a second hand 2213 for a good price. it had been used for about 3 years without issue (apparently!). i just cant seem to get the rattle out? i have a 2217 so i am familiar with the air issues etc that can cause noise. i've pulled apart & inspected the impeller & shaft & all seems fine, nothing broken, missing, dirty or loose that i can see. does the impeller usually need replacing after this time or is it possibly a lubrication problem? this filter has the media as opposed to the sponges that im used to, does it just take longer to get the air out of these ones? looking for experiences & advice. thanks!

Share this post


Link to post
Share on other sites

Maybe the motor isn't secured properly in the actual canister? If it is loose, it may rattle when turned on. :idont

Share this post


Link to post
Share on other sites

When I got my second hand eheim 2213 the same thing happened and I just bought a new white rod that goes in the motor thing I forgot what it was called

Share this post


Link to post
Share on other sites

When I got my second hand eheim 2213 the same thing happened and I just bought a new white rod that goes in the motor thing I forgot what it was called

The thing that has blades? That's the impeller. Replacing it can fix a lot of problems.

Share this post


Link to post
Share on other sites

When I got my second hand eheim 2213 the same thing happened and I just bought a new white rod that goes in the motor thing I forgot what it was called

The thing that has blades? That's the impeller. Replacing it can fix a lot of problems.
after I did some research before I bought it it said it's good to replace when you hear rattling

Share this post


Link to post
Share on other sites

When I got my second hand eheim 2213 the same thing happened and I just bought a new white rod that goes in the motor thing I forgot what it was called

The thing that has blades? That's the impeller. Replacing it can fix a lot of problems.
after I did some research before I bought it it said it's good to replace when you hear rattling

Yeah, that's right. It may also to help lubricate it with vaseline.

Share this post


Link to post
Share on other sites

When I got my second hand eheim 2213 the same thing happened and I just bought a new white rod that goes in the motor thing I forgot what it was called

The thing that has blades? That's the impeller. Replacing it can fix a lot of problems.
after I did some research before I bought it it said it's good to replace when you hear rattling

Yeah, that's right. It may also to help lubricate it with vaseline.
yeah that would probably help to

Share this post


Link to post
Share on other sites

i'm reading a lot that silicone oil is better than vaseline for lubricating impellers? the eheim maintenence spay is silicone based. i think lubricating will be the next step before buying a new impeller & shaft. someone even uses stress guard to lube their impellers! lol i actually had some of that & thought what the heck & gave it a go. not sure if its wishful thinking but i swear it seems a little quieter! :idont ha ha i'll get some silicone oil tomorrow

Share this post


Link to post
Share on other sites

ok, so i finally got some plumbers grease & lubed everything up nicely & put it back together.... it's now gone from a rattle to a loud hum, which becomes less if i apply pressure with my hand to the lid. i think next step will be a new impeller & shaft. i cant see anything wrong with this one but its still way noisier than my 2217 but not as noisy as the air pump! at least i can run it now while i source the replacement parts....

Share this post


Link to post
Share on other sites

Too bad the lubrication didn't fix it up :(

Share this post


Link to post
Share on other sites

new parts finally arrived! the only difference i can see it that the old impeller blade part is a lot looser on the white plastic shaft. eheim say there is a way to tighten this up but i couldn't for the life of me remove the blades from the shaft as they were instructing in order to do so! the ceramic impeller shaft looked fine but i swapped it for the new one anyway & it is all running a lot quieter now. will keep the old shaft as a spare.

also, having recently cleaned out the impeller on my 2217 for the first time in 2 years & removing all the gunk i have noticed it is not as silent as it used to be. i tried greasing the shaft which made little difference. i think with time they will both build up some gunk & natural lubrication & be on the road to dead silent again...

Share this post


Link to post
Share on other sites

Natural "gunk" is always the best way to keep a filter quiet for both HOBs and canisters. Over time, filters quiet down as they build it up and cleaning it out is a big no no. :yikes

I've been in an endless war with my new canister but I know I just have to wait it out. :cry

Edited by Chai

Share this post


Link to post
Share on other sites

re: cleaning the gunk out... i tend to learn things the hard way! :wall

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...